• ↓
  • ↑
  • ⇑
 
Записи с темой: программирование (список заголовков)
01:41 

Мы сделали!

А у меня тут отличные новости!

Первая большая и самая важная часть функционала нашего проекта вроде как готова! Сейчас будем готовить материалы для тестирования и тестировать!
Были разные сложности, были иногда непонятки между нами, но все это нам не помешало. И какие молодцы моя команда! Приятно работать с людьми, которые действительно любят свое дело, хотят развиваться и хотят увидеть результат не меньше тебя. Ну и просто они отличные, веселые ребята!

И вообще, для первого полноценного опыта руководства мне с ними безумно повезло. Не было каких-то личных конфликтов, никто не лез с позицией "Есть только два мнения - мое и неправильное!", почти не нужно было никого дополнительно пинать. Понятно, что когда-то со всем этим придется столкнуться, но для начала это просто чудесно.

Сейчас проверим то, что есть - и можно будет начинать следующую базовую часть!

@темы: Работа, Программирование, Жизнь

04:56 

Прогресс в разработке!

А на наш проект недавно пришел новый замечательный full-stack разработчик! И принес очень много хорошего. Мне посоветовал перейти с чистого Javasсript на TypeScript, буду его изучать, а главное, изучать, как сделать миграцию проекта React на него. Команде бэкенда он тоже очень помог. И еще скоро теперь должны решиться некоторые проблемы с веб-сервером.

А еще у нас теперь наконец-то нормальный репозиторий с бранчами для фронтенда и бэкенда. Научилась работать с бранчами, очень счастлива теперь. :)

И вообще это просто счастье что он к нам пришел! А то всё-таки печально было, когда бэкенд делали люди - хорошие, очень хорошие разработчики, но раньше почти не работавшие с вебом.

@темы: Работа, Программирование, React

18:53 

lock Доступ к записи ограничен

Закрытая запись, не предназначенная для публичного просмотра

URL
23:02 

Позор веб-разработки!

Сегодня посмотрела интересный вебинар на GeekBrains про ООП в Javasсript. Некоторые действительно новые вещи услышала.

Потом стала смотреть, а что еще есть на GeekBrains, и нашла раздел Тесты. Предлагаются тесты на разные темы, примерно из 30 вопросов, которые надо пройти за 10-15 минут. В случае успеха можно скачать электронный сертификат!)) В случае неудачи можно через некоторое время попробовать еще раз. Ну, подумала я, а почему бы и не попробовать!

читать дальше
запись создана: 01.10.2016 в 21:42

@темы: Работа, Программирование, Верстка, jQuery, PHP, .NET

00:00 

Проект растет

А наш проект потихоньку растет. К огромной моей радости запуск перенесли с августа на сентябрь, и теперь есть надежда, что мы выпустим не черт знает что, что нужно будет в панике доделывать, а что-то более-менее нормальное.

Для меня это первый такой масштабный проект. И мало того, что моего JS-кода стало гораздо больше, чем я раньше писала, так еще и я пишу часть бэкенда, с использованием совершенно нового незнакомого фреймфорка, ASP.NET, и с использованием практически незнакомого языка - C#. Раньше я знала только самые его основы. И ощущения от этого проекта очень интересные.
читать дальше

@темы: Программирование, Новый ЛК, Верстка, Работа, React, .NET

14:06 

Наш проект растет и начинает уже быть на что-то похожим.

А мне всё больше нравится asp.net. Многие вещи на нем делать как-то гораздо проще чем на PHP, который все почему-то считают самым легким языком для web-разработки. И уж точно там гораздо проще отлаживать программу!

Единственным неприятным сюрпризом от asp.net стало то, что при компиляции он меняет указанный id элемента на сгенерированный, в результате не работают некоторые фишки типа

Но это можно обойти.

А как я этого asp.net боялась сначала! Все еще говорили, такая сложная штука, такая сложная, ужасжуть прям! Да ничего подобного! Разве что информации о нем в рунете мало, а не на каждом столбе, как про PHP. Так что очень надеюсь, что мое общение с asp.net будет долгим и приятным!

А еще нам уже второй месяц выдают зп не только вовремя, но и на день раньше.

@темы: Работа, Программирование, Новый ЛК, Верстка, PHP, .NET

10:25 

Начали работу над проектом

Вчера наконец-то начала верстать наш новый ЛК. И весь прикол в том, что уже завтра надо показать более-менее готовую главную страницу, пока без серверного функционала, но зато с разными радующими глаз простого юзера красивостями.

Ну, ничего страшного! Поработаю пару дней из дома. И хорошо, что делаем пока без интеграции с .NET, а то ведь наверняука там сначала сюрпризы будут!

@темы: Верстка, Новый ЛК, Программирование, Работа, Феаноринг, прояви фантазию!

22:45 

ASP. NET

Установила сегодня новую версию Visual Studio и попробовала разобраться с ASP.NET.

Пока вроде ничего сложного. Оказалось, что файл .aspx - это по сути аналог .html, никакой особой магии для него не надо, кроме специальной среды разработки. Стили, скрипты и прочее подключаются точно также, как и обычно.

А я боялась, что какой-нибудь ужас-жуть будет. Думаю, сюрпризы еще появятся, и надо будет разобраться с новыми возможностями, которые дает язык, но в целом вроде ок.

@темы: .NET, Верстка, Программирование, Работа

00:29 

PHP и jQuery

Я смог, я сделаль! ©

Я сегодня впервые в жизни написала полноценное клиент-серверное взаимодействие на PHP и jQuery!

Я разобралась в запутанном чужом коде, разобралась, как должны взаимодействовать два языка.
И вот всё это практически готово! – к огромному моему, если честно, удивлению. :)

Ведь еще сегодня утром я понятия не имела, как всё это должно работать и взаимодействовать, и как решать поставленную задачу. :)

А кстати да: уже почти две недели, как я перешла в наш IT-отдел, правда, пока неофициально.

@музыка: Accept - All or Nothing

@темы: Феаноринг, прояви фантазию!, Работа, Программирование, Компы, jQuery, PHP

01:28 

Я сегодня днем)


@настроение: Довольное)

@темы: Программирование, Компы, Работа

11:53 

Доступ к записи ограничен

Закрытая запись, не предназначенная для публичного просмотра

URL
02:19 

КонецЕсли

Давно я ничего не писала, но пожалуй, пришла пора сделать очередную запись)
Недавно был год, как я сдала ГОСы. И сколько же всего произошло за это время! И кто бы мог подумать тогда, что через год всё будет так, как есть сейчас?...

Год получился сложным, но принес много хорошего. Я бросила свою дурацкую экономику и с помощью одного прекрасного человека начала учиться любимому делу; он помог мне поверить, что в этом и есть мой талант, поверить в себя в этом смысле.

Затем, я познакомилась со многими замечательныими людьми!) Я переехала (целых два раза), с помощью друзей начала ремонтировать квартиру – и в процессе ремонта, пока я клеила там обои и выбрасывала старый хлам, эта квартира из места, где можно бросить вещи и поспать, действительно стала мои домом. И еще как никогда стало заметно за этот год, что я не одна в этом мире, рядом со мной друзья, готовые и помочь, если что, и не дать умереть с голоду, и поддержать в очередной безумной авантюре. :)

А после завершения ремонта (первого его этапа) стала я искать работу. Все мои мытарства по разным компаниям описывать нет смысла, скажу только, что в результате занесло меня внезапно в работу с 1С! Сейчас прохожу обучение, и скоро, надеюсь, начну работать. Обучение интересное, и, что немаловажно для человека с ночным образом жизни, проходит оно наполовину заочно. И вот сегодня в процессе обучения я смогла наконец увидеть таинственный язык 1С.

Он на русском!!! Первое впечатление такое, что Basic взяли и перевели на русский, и выглядит это... Бесподобно)) Вместо "While... Wend" получилось "Пока... КонецЦикла", вместо "If... EndIf" - "Если... КонецЕсли"! :alles: А еще - ИначеЕсли (ElseIf?..), а еще там вроде активно используется Goto... ах, ну да... Перейти! НЕт, я всё понимаю, но КонецЕсли!!! Звучит, как название какого-то отвратительного фильма-постапокалепсиса) Или как какой-то мрачный приговор. Все, не будет больше никаких "Если"! Твоя судьба предрешена!))) Но - а почему нет? Это хоть и странное, но тоже программирование, эжто интересная работа, деньги, в конце концов. Главное, нормальные языки тем временем не забыть, а, наоборот, доучить до нормального уровня.

Так что на данный момент мне вполне нравится, как всё складывается, и я верю, что скоро, так или иначе, все станет совсем хорошо)

@настроение: Заинтересованное

@темы: Работа, Программирование, Компы, Жизнь,

Запечатленное время

главная